[Cocci] [PATCH 1/5] powerpc: rename setbits32/clrbits32 to setbits32_be/clrbits32_be

LABBE Corentin clabbe at baylibre.com
Mon Sep 10 20:50:39 CEST 2018


On Mon, Sep 10, 2018 at 07:16:56AM +0200, Christophe LEROY wrote:
> 
> 
> Le 07/09/2018 à 21:41, Corentin Labbe a écrit :
> > Since setbits32/clrbits32 work on be32, it's better to remove ambiguity on
> > the used data type.
> 
> Wouldn't it be better to call them setbits_be32() / clrbits_be32() to 
> have something looking similar to in_be32() / ou_be32() ?
> 

I agree, I will update the patch.

Thanks



More information about the Cocci mailing list