[Cocci] about cocci installing

Julia Lawall julia.lawall at lip6.fr
Tue Aug 28 06:00:37 CEST 2018



On Tue, 28 Aug 2018, linjia at ruijie.com.cn wrote:

>
> Dear sir:
>
>   I try to install cocci by opam in centos, but failed as following
>
>  
>
> [root at localhost]# opam install coccinelle
>
> [WARNING] Running as root is not recommended
>
> Your request can't be satisfied:
>
>   - No package matches coccinelle.
>
>  
>
>  
>
> And I didn’t find packages for centos on homepage of cocci
>
>  
>
> Packages exist for several distributions:
>
>  *  Slackware, thanks to Dimitris Zlatanidis
>  *  Debian, thanks to Eugeniy Meshcheryakov
>  *  Ubuntu See also the Ubuntu package on PPA, which contains a more recent version of Coccincelle.
>  *  Fedora, thanks to Richard W.M. Jones and Michal Schmidt
>  *  OpenSUSE
>  *  Arch Linux, thanks to Sylvain HENRY
>  *  NetBSD, thanks to Thomas Klausner
>  *  FreeBSD
>  *  OpenBSD
>  *  Gentoo
>
> So is there ready packages for download and installing ? thanks a lot!

Not that I know of.  Could you just get the github version and compile it
yourself?  That way you will have the most up to date version anyway.

julia


More information about the Cocci mailing list