[Cocci] [PATCH v2 2/5] Documentation: Add doc for runchecks
knut.omang at oracle.com
Mon Dec 18 18:05:33 CET 2017
On Mon, 2017-12-18 at 17:23 +0100, SF Markus Elfring wrote:
> > I'll take these in for v3 as well and carefully review myself
> > for any further errors of the same sorts..
> I suggest to consider a few additional wording adjustments.
> > +``runchecks``. You can for instance use::
> +``runchecks``. You can use for instance::
> * Do you care for the handling of orphaned words in paragraphs?
Will look over it, thanks.
> * Was any consensus achieved already for corresponding names?
> x Could a longer variable name like “CHECKING_FLAGS” be easier to remember
> than the proposed “CF”?
I kept CF as is already established as the flag to use for parameters with C=
> x Will the naming style matter (if you compare the approaches “checkpatch”
> and “get_maintainer”)?
No consensus made on the naming, just that I tried using verbatim names from sparse, eg
lowercase-dash vs UPPERCASE_UNDERSCORE as in checkpatch and found the runchecks.cfg and
reporting lines more easy to read using the uppercase variants, and that it looks more
nice to have a uniform output across checkers.
I think that the visual output of a test is important, as even we developers tend to be
more happy with (and willing to execute) programs that produce nice output vs ones with
ugly, cluttery, inconsistent output :-)
More information about the Cocci