[Cocci] [PATCH v2] fs-fat: Less function calls in fat_fill_super() after error detection
julia.lawall at lip6.fr
Tue Dec 2 08:37:32 CET 2014
On Tue, 2 Dec 2014, Dan Carpenter wrote:
> On Mon, Dec 01, 2014 at 10:22:38PM +0100, SF Markus Elfring wrote:
> > >> Which names would be better acceptable for you?
> > >
> > > You named it after the goto location but the label name should be based
> > > on the label location to say what the goto does.
> > I find it easier occasionally to name a label similarly to the jump target.
> That is a useless thing to do.
> > It seems that there are a few variations used for the affected identifiers.
> There is a lot of crap code in the kernel, yes.
Does the label naming strategy appear in the conding style documentation
anywhere? There are so many variants that just from looking at the code,
it is hard to guess what is the best strategy. For example, out1, out2,
etc are pretty uninformative, but they are concise and easy to spell
More information about the Cocci